Jump to content



Recommended Posts

So long story short my AOS addiction is giving me serious withdrawal symptoms due to the fact i cant play!!!!


when the new patch came out i couldnt play it so i stupidly tried to fix it within the depths of my mac


i accidently deleted the entire blizzard folder rather then just the cache in my shared folder.


now i get nothing but the "could not download authentication module" error


i have tried deleting it again, deleting the cache, resotoring the blizzard folder from a back up, changing DNS number and releasing, reinstalling SC2 and getting very little help from blizz support.


i have also noticed two letters of text on my login page that shouldnt be there "us" in white


tell me someone out there has some ideas for me.


PLEASE!!!!!! :)


many thanks in advance



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...