Jump to content

About the Lag.


EKCO

Recommended Posts

Blizzard is working on it, it's a server-sided issue. Some games won't notice it as much because their gameplay isn't affected by low FPS (Nexus Wars / STD). Games that do notice it are all response-time dependent (ie: 1v1 Obs). We want to fix it too, and we're talking to Blizzard to make sure it gets looked at.

 

EU/SEA/KR servers are working fine at this time, and we are looking to get 10 EU accounts so that players can resume inhouses and practice for the upcoming tournaments.

 

 

In the meantime, enjoy some Fresh Prince.

 

Link to comment
Share on other sites

Any idea of when it will be fixed for US servers? Cause I'm too cheap and lazy to get on another server. I noticed that the lag was the worst with certain heroes, Nova, Marine King, and Egon, possibly shadow. I had a game where there was no lag on US server, and none of these heroes were in the game, just a word to maybe isolated the cause, or it could just have been luck :P.

Link to comment
Share on other sites

It is obviously not just a server side issue. The fact they say it is a server side issue suggests something is seriously messed up with their multithreading code. The UI should not become responsive because the message updates are arriving late or else getting clogged up (since they stream stuff now which is obviously gonna have big side effects). I mean, this is user interface 101 when dealing with networking applications. By the sound of things it seems like they have SCII still running in one giant game loop where events whether they are input related or network related are all read off the same queue and then and only then is the UI repainted/updated. Obviously writing code in this way is easier on the game developer but generally bad practice when it comes to any application these days. Concurrency is hard stuff, but these guys are supposed to be professionals.

 

Of course it could be something totally different, but based upon the nature of what is going and my experience in the past in dealing with similar programming issues, this seems like the obvious problem in that there is no real BUG per se, rather the way they are doing things suggested an inherent design flaw in how they have the SCII client interacting with Battle.net and they are programming games like it is 1999.

 

So they either have to change their application design, or else Battle.net needs to be flawless in its delivery of game messages which is unlikely given that they have moved to a streaming method of sending data around so that the design flaws are invisible to the user.

 

No way for me to know for sure unless I were to ask them myself or see the source code, which of course is not going to happen since they are very secretive about all of that, but nevertheless the fact Blizzard claims this is a "server side" problem when it is more of a general design problem with the client which should still be responsive and not freeze up even if there is lag, suggests things may never get fixed. Hopefully, I am very wrong and THEIR solution is to simply add more servers and bandwidth and everything will work nicely as before, but unfortunately the unreliability of getting consistent quality of service across multiple parties over the internet suggests AoS might end up RIP along with some other custom games unless Blizzard makes some serious design changes (no idea exactly how they were doing things befroe 1.5 but whatever they were doing, at least things worked).

Link to comment
Share on other sites

Does lowering graphix settings help at all? I've also noticed if someone drops during load the game normally won't lag. I for one dont get lag in every game its only rarely and normally the game says "x is slowing down the game" Hope this gets fixed soon, wish they would just go back to before streaming.

Link to comment
Share on other sites

Does lowering graphix settings help at all? I've also noticed if someone drops during load the game normally won't lag. I for one dont get lag in every game its only rarely and normally the game says "x is slowing down the game" Hope this gets fixed soon, wish they would just go back to before streaming.

 

I tried lowering my graphics to low. It helped to postpone the lag only slightly, as the lag after this patch is inevitable. Curse blizzard!

Link to comment
Share on other sites

In West Philadelphia, Born and Raised, on the playground is where I spent most of my days.

 

I can play with minor lag until about 30 mins in, then it can get a bit difficult. Thankfully, I don't usually experience this 0-5 FPS people speak of, all game long...

 

So even after 30 minutes you don't get the 0-5 fps? I can't even control my unit after that, let alone buy items...

Link to comment
Share on other sites

So even after 30 minutes you don't get the 0-5 fps? I can't even control my unit after that, let alone buy items...

 

In random games, but generally I am at like 15 fps end game. No I don't have a monster computer. I have a meager laptop :

http://www.shopping.hp.com/en_US/home-office/-/products/Laptops/HP-Pavilion/C0L25AV?HP-Pavilion-dv6t-7000-Select-Edition-Entertainment-Notebook-PC

Link to comment
Share on other sites

IT WORKSKSKSKSKS OMGOMGOMG

 

If you join a game with a spec, and the spec leaves/drops during the load screen AND ONLY the load screen, the remainder of the game between even a 5v5 can be played perfectly without any lag. SO WEIRD. TRY IT WITH YOUR FRIENDS and SPREAD THE WORD

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...