Jump to content
Geneon

Patch 2.0.4 lag issues?

Recommended Posts

Geneon   

This recent Starcraft patch is the biggest one yet and I've noticed that a lot of people have been lagging in-game myself included. I did a few digging and found a thread about the issue. I must apologize but I'm on my phone and cant find the link since I originally found it on my desktop. If you're experiencing the lag it may be because of how the launcher for this patch worked. Even though you completed the main download that had focused on the new interface, there are additional content that is for the upcoming HOTS that doesn't show after completion of the download on the launcher.

 

To view this extra download, open up starcraft launcher. On the upper left hand corner you should see a tab about downloads. After clicking, you should see something like "download connection." A pop up should show your download speed, upload speed, seeding etc. Most importantly it shows how much of the total download you completed.

 

The launcher only shows about 9.5 gigs whereas the entire download is actually 14 gigs.

 

Normally, when you press the play button, all downloads stop. But (I'm assuming) blizzard messed up a bit on this one and the launcher continues to download despite pressing the play button causing the unwanted lag in-game. Monitor the download and be sure that the 14g completes fully. Hopefully this helps anyone who are having some lag issues.

Share this post


Link to post
Share on other sites

Did you have lag or latency? I solved my latency problems with CTRL+SHIFT+ESC then going Performance then Network then deleting "Agent.exe" I did it in mid of a game and it worked instantly, you maybe would like to try it.

My game had like 5 flobing sec latency and they just dissapeared after doing that.

Share this post


Link to post
Share on other sites
Geneon   

I had some yes but after completing fully the lag is gone. Even the majority of people I've seen on the battle net site was just because of the "hidden" download that was giving them lag issues. Thanks for posting the additional information, hopefully it'll help others as well.

Share this post


Link to post
Share on other sites
Dom   

It no longer "normally" stops the download queue when you push play in the SC2 launcher. Blizz announced (at least on the Diablo or WoW launcher news, can't remember which) that they've introduced a new way to patch up. It'd keep a Blizz downloader active, but hidden from view and patch your game up when new content is getting ready to be released. They're doing it at the moment with the 5.2 WoW patch and doing it with the 2.x HotS patch (obviously :P). Only remedy I've found is to either let your game patch up entirely or shut down the Blizzard downloader from the task manager.

 

TL;DR - lag happens because someone still has their downloader active and can't handle the game/patching with bandwidth issues.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×